REMARK – use *** ¬†puppet facts find <servername> –render-as yaml | grep sap_ora Make a custom fact (ruby code) that determins the Oracle version SAP is using. Under ¬†modules tree /modules/<module_name>/lib/oracleversion.rb   Facter.add("sap_oracleversion") do confine :operatingsystem => 'SLES' if Facter.value(:sapprepsids) != nil setcode do result = "none" sapprep_sid = Facter.value(:sapprepsids) first_sid = sapprep_sid.to_s.split(',')[0] second_sid =